Page 5 of 6 FirstFirst ... 3 4 5 6 LastLast
Results 61 to 75 of 81

Thread: it has begun!

  1. #61
    2002 HD
    Name:

    Drewbo's Avatar
    Join Date
    Mar 2011
    Location
    Hollywood, Cali
    Posts
    19
    Like
    0
    Liked 0 Times in 0 Posts

    Nice

    Okay, I have no real clue as to what you have done. Except for the fact that everything looks really clean and I have a strange excitement/jealousy that I can't explain. Very cool and way to go. Enjoy!

  2. #62
    Registered User
    Name: Rich

    tpr103's Avatar
    Join Date
    Apr 2004
    Location
    nj
    Posts
    3,314
    Like
    12
    Liked 46 Times in 33 Posts
    well a little progress. i picked up filters and fluids, and a new water pump. other then that i havent touched her since tues.

    tuesday josh came over again to help me. after he left monday night i got to work installing the starter and noticed something missing! the damn starter plate. so we got it banged out real fast. after josh left i was in the garage wrenching away til 4am. got the headers, O2s, starter, and everything else underneath done. been at a stand still cause i can not decide which valve covers i wanted to use. i decided to go with the ghost skulls
    Attached Images Attached Images
    Last edited by tpr103; 04-02-2011 at 01:50 AM.

  3. #63
    2002 HD
    Name:

    Drewbo's Avatar
    Join Date
    Mar 2011
    Location
    Hollywood, Cali
    Posts
    19
    Like
    0
    Liked 0 Times in 0 Posts

    Thumbs up

    Can't go wrong with ghost skulls no matter where they are.
    Attached Images Attached Images

  4. #64
    Registered User
    Name: Rich

    tpr103's Avatar
    Join Date
    Apr 2004
    Location
    nj
    Posts
    3,314
    Like
    12
    Liked 46 Times in 33 Posts
    well i had to change where i mounted the fuel press. reg. so that meant ordering more fittings. so i had to wait for those to come in.

    progress for tonight errr day. i finished up around 5:30 am truck is done! cant fire her up though cause i need one more freaking fitting and i broke one of the lines on the evap solenoid. now i have to get another one. so if anyone reading this has one i want it.

  5. #65
    World's Fastest Street HD
    Name: Josh

    Harley#356's Avatar
    Join Date
    Jan 2003
    Location
    NJ
    Posts
    31,073
    Like
    0
    Liked 6 Times in 6 Posts
    Quote Originally Posted by lenny2001harley View Post
    yeah thanks im gettin the l/s harness from mad
    what else do you have for sale? let me know
    I'm guessing you have the L fuel hat? Just cut the connector off your stock fuel hat and wire it to the L fuel hat, then it's plug and play. Thats what I did on my street truck.


    Rich...is it running yet?!?!?!?

  6. #66
    Registered User
    Name: Rich

    tpr103's Avatar
    Join Date
    Apr 2004
    Location
    nj
    Posts
    3,314
    Like
    12
    Liked 46 Times in 33 Posts
    it cranked over lol. however i found some fuel leaks

  7. #67
    Registered User
    Name: Rich

    tpr103's Avatar
    Join Date
    Apr 2004
    Location
    nj
    Posts
    3,314
    Like
    12
    Liked 46 Times in 33 Posts
    IT RUNS!!!!!!!!! i rigged my old evap for the time being. i drilled out where i snapped the vac. port off and stuck a vac nipple in there for the time being just to get it fired up. yesterday i pulled the fues to the pumps and cranked the motor to build oil press. then i re-installed the fuse, and primed the pumps! found 2 leaks, one by the fpr which was an easy fix, just had to tighten it. the other one was not so easy, #2 cyl fuel injector upper oring. i must have nipped it when i installed it. frustrated and running outta time, since i had to go out to dinner with the family i calle dit a night.

    today i pulled the rail and injector. sure enough the oring had a chunk taken out of it. went to pepboys and was surprised they actually had it. came back and put her all back together again. went to fire her up and the battery was dead. tried charging it but wasnt taking or holding a charge? luckily over the winter i replaced the battery in my L with a new optima. i took the hd's optima back to peps and got it replaced using the L receipt. once again back home batt hooked up. primed the pumps looked good no leaks. fire in the hole! she fired right up and idled perfect!ran her for about 20 mins. let the paint on the headers burn and smoke for a bit, still no leaks.

    still got some things to do before she hits the road. have to remake the fpr bracket, install the new evap (thanks again eric i owe you some beers!), reinstall the bumper, h/e, grill heads and corners, wheel liners and wheels. hope to have her backed outta the garage tonight so i can give her some much needed tlc on the outside!

  8. #68
    World's Fastest Street HD
    Name: Josh

    Harley#356's Avatar
    Join Date
    Jan 2003
    Location
    NJ
    Posts
    31,073
    Like
    0
    Liked 6 Times in 6 Posts
    done yet done yet done yet!??!?!!?!!?

  9. #69
    Registered User
    Name: Rich

    tpr103's Avatar
    Join Date
    Apr 2004
    Location
    nj
    Posts
    3,314
    Like
    12
    Liked 46 Times in 33 Posts
    Quote Originally Posted by Harley#356 View Post
    done yet done yet done yet!??!?!!?!!?
    umm read the post above you.

  10. #70
    World's Fastest Street HD
    Name: Josh

    Harley#356's Avatar
    Join Date
    Jan 2003
    Location
    NJ
    Posts
    31,073
    Like
    0
    Liked 6 Times in 6 Posts
    Quote Originally Posted by tpr103 View Post
    umm read the post above you.
    you read the post above me!


    "still got some things to do before she hits the road. have to remake the fpr bracket, install the new evap (thanks again eric i owe you some beers!), reinstall the bumper, h/e, grill heads and corners, wheel liners and wheels. hope to have her backed outta the garage tonight so i can give her some much needed tlc on the outside!"


    So....IS IT DONE YET?!?!?!?!?!??!

  11. #71
    Registered User
    Name: Rich

    tpr103's Avatar
    Join Date
    Apr 2004
    Location
    nj
    Posts
    3,314
    Like
    12
    Liked 46 Times in 33 Posts
    oh lol then no it isnt done yet. im still waiting on the evap. i guess my little rig job on int didnt seal all the way. had the truck running the other day for probably 20 min and all of a sudden i hear a loud his and see smoke! im like CRAP i run over and shut her off. then i remember the damn evap on that truck was always loud.

  12. #72
    Registered User
    Name: Rich

    tpr103's Avatar
    Join Date
    Apr 2004
    Location
    nj
    Posts
    3,314
    Like
    12
    Liked 46 Times in 33 Posts
    got the new evap solenoid going to install it tonight and drive her tomorrow

  13. #73
    World's Fastest Street HD
    Name: Josh

    Harley#356's Avatar
    Join Date
    Jan 2003
    Location
    NJ
    Posts
    31,073
    Like
    0
    Liked 6 Times in 6 Posts
    where's the finished pics? and when we having a GTG?!

  14. #74
    Registered User
    Name: Rich

    tpr103's Avatar
    Join Date
    Apr 2004
    Location
    nj
    Posts
    3,314
    Like
    12
    Liked 46 Times in 33 Posts
    dont know on the gtg. and i have to take some pics

  15. #75
    World's Fastest Street HD
    Name: Josh

    Harley#356's Avatar
    Join Date
    Jan 2003
    Location
    NJ
    Posts
    31,073
    Like
    0
    Liked 6 Times in 6 Posts
    Still waiting!!! lol

    On pics, and setting up a GTG!

Page 5 of 6 FirstFirst ... 3 4 5 6 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •