Results 1 to 7 of 7

Thread: fuses

  1. #1
    Registered User
    Name:

    Massive1's Avatar
    Join Date
    May 2011
    Location
    956 Tx.
    Posts
    551
    Like
    0
    Liked 7 Times in 6 Posts

    fuses

    Anyone have the fuse guide for the fuse box on the engine bay and the one under the dash for an 02?
    OBJECTS IN MIRROR ARE LOOSING

  2. #2
    Mobbin around the NW
    Name: Derek

    SonicHD's Avatar
    Join Date
    Feb 2008
    Location
    Newberg, OR
    Posts
    1,970
    Like
    116
    Liked 114 Times in 84 Posts

  3. #3
    Registered User
    Name:

    Massive1's Avatar
    Join Date
    May 2011
    Location
    956 Tx.
    Posts
    551
    Like
    0
    Liked 7 Times in 6 Posts
    Pictures no longer available on that thread, anyone know the location of the fuse/relay for the horn. Can't find it anywhere

  4. #4
    Registered User
    Name:

    Massive1's Avatar
    Join Date
    May 2011
    Location
    956 Tx.
    Posts
    551
    Like
    0
    Liked 7 Times in 6 Posts
    My bad, link does work now. Might of been my internet, checked bot fuses and relay still no horn, checked ground on horns, ground is good but still no power to the plug

  5. #5
    Worlds Shiniest HD F-150!
    Name: ]\/[ike

    Merlin's Avatar
    Join Date
    Jul 2009
    Location
    Sunny South Florida
    Posts
    4,229
    Like
    45
    Liked 165 Times in 135 Posts
    Looks like you found it.

  6. #6
    Registered User
    Name:

    Massive1's Avatar
    Join Date
    May 2011
    Location
    956 Tx.
    Posts
    551
    Like
    0
    Liked 7 Times in 6 Posts
    Followed all wires, unhooked the engine bay fuse box and checked all wires there too, the wires from the horn fuse have power, then those connect to the horn relay, when i tested the power on the relay the truck starts honking as soon as i touch the leads. But still no horn from the inside of the cab, i guess its a trip to the mechanics shop

  7. #7
    Registered User
    Name: Marco


    Join Date
    Sep 2013
    Location
    Austin TX
    Posts
    2
    Like
    0
    Liked 0 Times in 0 Posts
    Massive1 - Did you ever find the cause for the horn not working ? Having the same issue, I have gone as far as replacing the Airbag Clock Spring. But still no horn. All fuses and relays working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •