Results 1 to 6 of 6

Thread: Stuck, need advice.

  1. #1
    Registered User
    Name: Ted


    Join Date
    Oct 2015
    Location
    Mesa Arizona
    Posts
    45
    Like
    6
    Liked 8 Times in 5 Posts

    Stuck, need advice.

    Getting close to completiing my harley swap. Asembeled front pulleys including pulley bridge, went to atttatch clutch fan and two threads in it hits the belt tensioner. Not good, i am at a loss how to rectiy this. If this means electric fans i have searched the forums and everyone points to madenenterpise, which according to what i found no longer exists. If you provide electirc fan options please direct to the best setup budget wise. I am stuck and dead in the water now.

  2. #2
    Mobbin around the NW
    Name: Derek

    SonicHD's Avatar
    Join Date
    Feb 2008
    Location
    Newberg, OR
    Posts
    1,964
    Like
    116
    Liked 114 Times in 84 Posts
    Funny you mention. I have a brand new, complete madenterprise fan kit. I purchased it maybe 6 months or so before he passed. Fan, shroud, controller, everything up in the attic I will be willing to sell.

    As a matter of fact, I may have a sh*t load of parts for sale soon.

  3. #3
    aka not rite
    Name: Bob

    B.O.B.'s Avatar
    Join Date
    Jan 2015
    Location
    Illinois
    Posts
    468
    Like
    37
    Liked 55 Times in 44 Posts
    Quote Originally Posted by SonicHD View Post
    As a matter of fact, I may have a sh*t load of parts for sale soon.
    "Cleaning house" or are you leaving us for one of those other forums? You didn't go out and get one of those gm products did you? Lol

  4. #4
    Registered User
    Name: Ted


    Join Date
    Oct 2015
    Location
    Mesa Arizona
    Posts
    45
    Like
    6
    Liked 8 Times in 5 Posts

    Interseted

    Quote Originally Posted by SonicHD View Post
    Funny you mention. I have a brand new, complete madenterprise fan kit. I purchased it maybe 6 months or so before he passed. Fan, shroud, controller, everything up in the attic I will be willing to sell.

    As a matter of fact, I may have a sh*t load of parts for sale soon.
    Hello, how much for the kit and shipping? I live in mesa az. I have no idea what i should be putting on this truck, i have seen alot of posts refering to this setup and it sounds like it will work fine on my 2003. My number is 480-570-2762. You can let me know on here or call. I am needing it yesterday as this is where i am stuck.

    Thank you

    Ted

  5. #5
    Registered User
    Name: Allen

    throttle jockey's Avatar
    Join Date
    Feb 2007
    Location
    San Diego
    Posts
    391
    Like
    4
    Liked 92 Times in 56 Posts
    Ted, e-fans might get you on the road but it doesn't answer the underlying question of why you can't use the factory clutch fan. Personally that would drive me nuts. Did you visually compare your water pump to the one shown in the link I posted in your other thread? To me it looks like the shaft on your water for the fan is shorter than the shaft of a factory L/HD water pump. If that's the case it makes me wonder what pump is on the motor you bought.

  6. The Following User Liked throttle jockey For This Useful Post:

    Sport90 (10-21-2015)

  7. #6
    Registered User
    Name: Ted


    Join Date
    Oct 2015
    Location
    Mesa Arizona
    Posts
    45
    Like
    6
    Liked 8 Times in 5 Posts
    Hello Derek, what I discovered was I had replace that water pump some time back in when I did I put a stock 5.4 L water pump on it. Which worked fine at the time because the Allen industries supercharger ran off of the accersory pulleys, so it wasn't necessary for it stick out any further, until I put the Harley Davidson set up on the engine . I did purchase the Harley Davidson water pump today and installed, now everything lines up perfectly. I did discover a new issue, the wiring harness that I bought with all of the stuff from the Harley Davidson was from a Harley Davidson which would've worked perfect on my truck except for the fact that my truck is a four-wheel-drive so it had no electronic four-wheel-drive wiring in the harness. So I took it off of the old harness and re-pinned it into the fuse relay box and into the three plugs that go into the firewall. Took about four hours but I got it done . Tomorrow, Saturday and Sunday big days going to finish putting everything on finish the vacuum lines put some fluid in it plug the battery back in and turn the key on to see if anything works. Dyno is scheduled for Tuesday I will keep you posted and hopefully be able to post some pictures of the finished product. I plan on putting together a how-to to swap a stock 5.4 over to the Harley conversion including wiring harness and everything else. Hopefully be able to give back to the national Harley truck owners club. One question, if I were to decide to replace the lower pulley what would be an inexpensive route to go? The stock pulley on it now is the caged one, i dont like the fact that if i had to replace the accerory belt i would have to take that off.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •