Results 1 to 3 of 3

Thread: 03 harley idling at 2000 rpm

  1. #1
    Registered User
    Name:


    Join Date
    Jan 2011
    Location
    new orleans
    Posts
    107
    Like
    4
    Liked 2 Times in 2 Posts

    03 harley idling at 2000 rpm

    not sure if this is the correct place to post this question but my question is I have a 03 Harley daivdson was idling fine test drove it for 5 mins then when I got back from the test drive when vechile is in park it idles at 2000 rpm once u put it in gear drive or reverse it drops to 1000 rpm where it should be at before I test drove it didn't do this after I test drove it does this I even disconnected the iac sensor while it was running usally that kills the motor but it was like I didn't even unplug the sensor has any body run across the issue or can tell me what to do to fix the problem ? any help I will be greatful thank yall in advance

  2. #2
    Mobbin around the NW
    Name: Derek

    SonicHD's Avatar
    Join Date
    Feb 2008
    Location
    Newberg, OR
    Posts
    1,913
    Like
    105
    Liked 106 Times in 77 Posts
    I would think it's the IAC or TPS (throttle position sensor on the side of the throttle body). Take the IAC off and clean it out with WD40. It could just be sticking, or need replacing. Also check your TPS sensor voltage, that could be messed up as well. There is a how to in the proper section that shows how to do so.

  3. #3
    Registered User
    Name:


    Join Date
    Jan 2011
    Location
    new orleans
    Posts
    107
    Like
    4
    Liked 2 Times in 2 Posts
    yeah I thought the same thing with the iac sensor but I pluged it with truck running it was like I didn't even unplug anything lol ill try the tps sensor thanks man any thing else u can think of ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •