Results 1 to 7 of 7

Thread: A/C Blows through Defrost Vent

  1. #1
    Registered User
    Name: 9126704170


    Join Date
    Mar 2017
    Location
    Waycross, GA
    Posts
    4
    Like
    0
    Liked 0 Times in 0 Posts

    A/C Blows through Defrost Vent

    Alright, here we go. I have an 2003 HD, When I put a/c on max it blows through the defroster vent on windshield and not through the dash vents. When I put it on vent it blows fine air but no cold a/c air. Is this due to needing recharge or ??????? Anybody got any thoughts on how to fix this? Thank you in advance for any suggestions.

  2. #2
    Registered User
    Name: mark

    bigmo's Avatar
    Join Date
    Oct 2015
    Location
    kingston tn.
    Posts
    62
    Like
    1
    Liked 0 Times in 0 Posts
    I think its o ring leakage in the controller....mine is starting to act weird too....seaech for heat/ac controls fix

    Sent from my SM-G900V using Tapatalk
    BigMo

  3. #3
    Registered User
    Name: BRIAN


    Join Date
    Dec 2014
    Location
    SOUTH CAROLINA
    Posts
    457
    Like
    109
    Liked 26 Times in 21 Posts
    YUP! good video on you tube ac control unit repair

  4. #4
    Rumblin Bumblin Stumblin
    Name:

    jmarvolous's Avatar
    Join Date
    Sep 2006
    Location
    Asheville, NC
    Posts
    1,611
    Like
    0
    Liked 5 Times in 3 Posts
    common problem...you can search for f150 eatc repair or potentially just buy a new one if you have to.

  5. #5
    Registered User
    Name: Bill


    Join Date
    Mar 2006
    Location
    California
    Posts
    4
    Like
    0
    Liked 0 Times in 0 Posts
    Definitely the o-ring fix in the controller. I just got through this recently and mine works like new now. You can find replacement o-rings at hardware/plumbing stores.

  6. #6
    Rumblin Bumblin Stumblin
    Name:

    jmarvolous's Avatar
    Join Date
    Sep 2006
    Location
    Asheville, NC
    Posts
    1,611
    Like
    0
    Liked 5 Times in 3 Posts
    anyone have an eatc for sale? i have the problem just havent fixed it

  7. #7
    Registered User
    Name: Byron

    GRANTBP's Avatar
    Join Date
    Nov 2008
    Location
    Dallas,Tx
    Posts
    1,242
    Like
    46
    Liked 10 Times in 10 Posts
    Bad oring in the controller you can fit it it just take time


    Sent from my SAMSUNG-SM-G900A using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •