Results 1 to 5 of 5

Thread: Tried / Trying to fix intermittent odometer issue in my 00

  1. #1
    Moderator
    Name: Patrick

    shanker's Avatar
    Join Date
    Feb 2003
    Location
    Portland, Texas
    Posts
    654
    Like
    0
    Liked 8 Times in 5 Posts

    Tried / Trying to fix intermittent odometer issue in my 00

    For a few years now I've just ignored the intermittent odometer as it's not an issue that affects drive ability.

    I tore it all apart today expecting to re soldier the soldier joints as countless other threads and forums indicate the issue being. Unfortunately I don't think this is the case for my truck as the corner of the actual display has a *burnt* edge. I'm thinking that I'm going to have to go to the local U-Pull-It and spend some time pulling apart a cluster in a truck there and get just the display.

    Has anyone here ever seen something like this?





    When the people fear their government, there is tyranny; when the government fears the people, there is liberty.
    Thomas Jefferson

  2. #2
    Registered User
    Name: Jim


    Join Date
    Nov 2017
    Location
    Pa
    Posts
    14
    Like
    0
    Liked 1 Time in 1 Post

    Tried / Trying to fix intermittent odometer issue in my 00

    Every screen Iíve even seen has the black in the corner, I wouldnít think thatís your issue

  3. #3
    Moderator
    Name: Patrick

    shanker's Avatar
    Join Date
    Feb 2003
    Location
    Portland, Texas
    Posts
    654
    Like
    0
    Liked 8 Times in 5 Posts
    Quote Originally Posted by Trcobra506 View Post
    Every screen I’ve even seen has the black in the corner, I wouldn’t think that’s your issue
    that's good to know...

    surprisingly enough...since I got it put back together, it hasn't blinked out....

  4. #4
    Registered User
    Name: richard


    Join Date
    Oct 2017
    Location
    del rio texas
    Posts
    4
    Like
    0
    Liked 0 Times in 0 Posts
    mine blacks out every once in a while i guess i should've checked connections etc when i tore apart the cluster because my turn signal wouldnt work when id use the tilt on my steering wheel

  5. #5
    Moderator
    Name: Patrick

    shanker's Avatar
    Join Date
    Feb 2003
    Location
    Portland, Texas
    Posts
    654
    Like
    0
    Liked 8 Times in 5 Posts
    Quote Originally Posted by elrey666 View Post
    mine blacks out every once in a while i guess i should've checked connections etc when i tore apart the cluster because my turn signal wouldnt work when id use the tilt on my steering wheel
    that's a different issue....typically from the connection at the back of the turn signal switch lever itself when the wheel is tilted downwards.....I fixed that by running a ziptie around the connection to prevent it from being pulled out when tilting the wheel down.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •