Results 1 to 4 of 4

Thread: New To Site and Need Help With My 2007 HD F150

  1. #1
    Registered User
    Name: Evin


    Join Date
    Jul 2018
    Location
    Tierra Verda
    Posts
    1
    Like
    0
    Liked 0 Times in 0 Posts

    New To Site and Need Help With My 2007 HD F150

    This is a great site and I am happy to be a member!

    I have a 2007 HD which I purchased new in 2008. It only has 55K miles and has had all scheduled maintenance. I need help with two issues: Intermittent severe missing under boost and cat replacements.

    Sometimes my truck runs normal with no issues and other times when I try to accelerate the boost gage immediately goes to 4PSI and the engine misses severely. I have had the catalytic converters replaced at 22K and 45K. I think that there is a problem which Ford has not fixed so I maybe looking at another replacement at 66K miles. The two times I have had them replaced (under warranty) the service writers told me that this is not unusual and may have been caused by bad injectors.

    I am looking forward to your ideas on what could be the problems causing my issues.

    Thanks!

  2. #2
    Huh?
    Name: Philip

    PhilthyPhil's Avatar
    Join Date
    Feb 2016
    Location
    North San Diego
    Posts
    363
    Like
    9
    Liked 32 Times in 24 Posts
    I am not hip on boost problems, but as far a your cats, replacement every 20k sounds a lil bit wrong. Maybe you can delete your cats altogether and tune out the CEL. Hopefully someone else will chime in soon.

    Besides that, welcome to the site, you got any pics.

  3. #3
    Word
    Name: Kevin

    Blind's Avatar
    Join Date
    Oct 2009
    Location
    Hella NorCal
    Posts
    2,342
    Like
    98
    Liked 62 Times in 58 Posts
    missing under load and the boost pegging easily does sound like an exhaust restriction caused by bad cats.

    I had a `97 gmc sierra pickup that killed 2 sets of cats, one set at about 90k, and the other set about 115k..After the 2nd set were rattling for a few months, on a long drive something plugged up in it...truck was basically undriveable and the exhaust got near silent, couldn't accelerate or go up hills. I wasn't into spending ~$900 on another factory Y-pipe so I just took the mid pipe off and used a steel rod to break apart all the cat material and bolted it back on with them empty. I was out of state when it happened and only took me a couple hours, got me home with no further incident other than the exhaust being a bit louder than it was before the cat problem.

    I got rear-ended in the truck shortly after and it was totaled, but my plan was going to be buying another factory Y-pipe and only swapping it on to pass smog every 2 years, that way the truck wouldn't eat them.

    After the first set of cats were killed, I had it at a shop and had them replace the fuel pump, fuel filter, the injector spider (gm trucks are weird in that early vortec generation), the spark plugs, the plug wires, the coil, and the distributor cap and rotor. Apparently none of that was the problem as it killed the replacement factory cats in about 25k miles
    2002 DSG HD #09617 NHTOC Truck of the month November 2012
    Ported eaton/plenum/tb, 6lb lower, SCT BA-2600 MAF, OBX longtubes, JLP intake, FTVB, L-spec bilsteins, Hotchkis TVS, 22" replicas. Tuned by Ray McClelland of FTK

  4. #4
    Worlds Shiniest HD F-150!
    Name: ]\/[ike

    Merlin's Avatar
    Join Date
    Jul 2009
    Location
    Sunny South Florida
    Posts
    4,125
    Like
    44
    Liked 153 Times in 123 Posts


    WELCOME to NHTOC!



    Let's see some pics!

    ... ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •